The issue affecting Multi-Zone signage has been fully resolved. Following the implemented fix, no lingering issues have been detected.
We will continue to monitor system performance, but all services are operating normally at this time.
Thank you for your patience and understanding while we worked through this.
Posted Feb 18, 2026 - 17:15 UTC
Monitoring
A fix has been deployed, and we’ve confirmed that Google and PowerPoint Web Slides in Multi-Zone signage is now functioning as expected.
Displays should no longer show the “Content Currently Unavailable” message. Signage may need to be restarted or toggled off and back on to fully clear the message.
We are continuing to monitor the system to ensure stability and will provide a final update once fully resolved.
Thank you for your patience.
Posted Feb 18, 2026 - 16:14 UTC
Identified
We have identified the cause of the issue affecting Multi-Zone signage layouts.
Our Engineering team is currently deploying a fix to restore normal functionality. We will continue to provide updates as progress is made.
Thank you for your continued patience.
Posted Feb 18, 2026 - 16:08 UTC
Update
Our Engineering team continues to actively investigate the issue affecting Google and PowerPoint Web Slides within Multi-Zone signage layouts, which may result in a “Content Currently Unavailable” message.
We are working to determine the root cause and will provide another update within the next hour or as soon as more information becomes available.
Thank you for your patience.
Posted Feb 18, 2026 - 15:44 UTC
Investigating
We are currently investigating an issue affecting Google and PowerPoint Web slides used within Multi-Zone signage layouts. Impacted displays may show a “Content Currently Unavailable” message in the affected zone.
At this time, this issue appears to be isolated to Google Slides within Multi-Zone configurations. Other content types and standard signage layouts continue to function as expected.
Our Engineering team is actively working to identify the root cause and restore full functionality as quickly as possible.
We apologize for the inconvenience and appreciate your patience. Updates will be posted here as soon as more information becomes available.